#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?![/*]])[^/* ]|^ *)@import ['"](.*?)['"](?![^*]*?\*\/)"
Local $sString = "@import "/my/path1"" & @CRLF & _
"/*" & @CRLF & _
"@import "/my/path1" " & @CRLF & _
"@import "/my/path2" " & @CRLF & _
"@import "/my/path3"" & @CRLF & _
"*/" & @CRLF & _
"/* @import "/my/path1" " & @CRLF & _
"@import "/my/path2" " & @CRLF & _
"@import "/my/path3" */" & @CRLF & _
"// @import "/my/path3"" & @CRLF & _
"/* @import "/my/path3" */" & @CRLF & _
" @import "/my/path3""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")