re = /(?:(?![\/*]])[^\/* ]|^ *)@import ['"](.*?)['"](?![^*]*?\*\/)/m
str = '@import "/my/path1"
/*
@import "/my/path1"
@import "/my/path2"
@import "/my/path3"
*/
/* @import "/my/path1"
@import "/my/path2"
@import "/my/path3" */
// @import "/my/path3"
/* @import "/my/path3" */
@import "/my/path3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end