$re = '/(?:(?![/*]])[^/* ]|^ *)@import [\'"](.*?)[\'"](?![^*]*?\*\/)/m';
$str = '@import "/my/path1"
/*
@import "/my/path1"
@import "/my/path2"
@import "/my/path3"
*/
/* @import "/my/path1"
@import "/my/path2"
@import "/my/path3" */
// @import "/my/path3"
/* @import "/my/path3" */
@import "/my/path3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);