package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\d]{2}\.\d+\b`)
var str = `10.1
50.555
100.45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}