$re = '/\b[\d]{2}\.\d+\b/';
$str = '10.1
50.555
100.45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);