const regex = /\b[\d]{2}\.\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[\\d]{2}\\.\\d+\\b', 'g')
const str = `10.1
50.555
100.45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}