package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(ABC002)|(01\/01\/2015)|(JNSDKJJOIJ)|(GREEN)|(000000)|(TEST)`)
var str = `"ABC002","01/01/2015","JNSDKJJOIJ","GREEN","000000","TEST"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}