re = /(ABC002)|(01\/01\/2015)|(JNSDKJJOIJ)|(GREEN)|(000000)|(TEST)/mi
str = '"ABC002","01/01/2015","JNSDKJJOIJ","GREEN","000000","TEST"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end