$re = '/(ABC002)|(01\/01\/2015)|(JNSDKJJOIJ)|(GREEN)|(000000)|(TEST)/mi';
$str = '"ABC002","01/01/2015","JNSDKJJOIJ","GREEN","000000","TEST"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);