#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]\S*(?:\s+[A-Z]\S*)*$"
Local $sString = "Fruits" & @CRLF & _
"fruits" & @CRLF & _
"" & @CRLF & _
"United States" & @CRLF & _
"United states" & @CRLF & _
"AZZ B " & @CRLF & _
"" & @CRLF & _
"C"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")