$re = '/^[A-Z]\S*(?:\s+[A-Z]\S*)*$/m';
$str = 'Fruits
fruits
United States
United states
AZZ B
C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);