package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]\S*(?:\s+[A-Z]\S*)*$`)
var str = `Fruits
fruits
United States
United states
AZZ B
C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}