using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^__test_[0-9]{13}__[A-Za-z0-9_]+$";
string input = @"__test_1349333576093__cellphone_modelc1
__test_1349333576090__macbook_model_12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}