const regex = /^__test_[0-9]{13}__[A-Za-z0-9_]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^__test_[0-9]{13}__[A-Za-z0-9_]+$', 'gm')
const str = `__test_1349333576093__cellphone_modelc1
__test_1349333576090__macbook_model_12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}