const regex = new RegExp('а?$', 'gm')
const str = `Скопирована`;
const subst = `о`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);