import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bAssert\\.Equal\\(\\K\\h*((?(R)[^()]*(?:\\((?1)\\)[^()]*)*|[^,()]*(?:\\((?1)\\)[^(),]*)*))\\h*,\\h*((?1))\\h*(?=\\))";
final String string = "Assert.Equal(false, General.CashFactor.IsHighlighted());\n"
+ "Assert.Equal(values, General.CashFactor.GetValue());\n"
+ "Assert.Equal(int.Parse(General.Time.Hour.GetValue()), this.GetLocalTimeEN(int.Parse(timezone.Timezone2.Zeitverschiebung), int.Parse(hour)));";
final String subst = "\\2, \\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}