const regex = /\bAssert\.Equal\(\K\h*((?(R)[^()]*(?:\((?1)\)[^()]*)*|[^,()]*(?:\((?1)\)[^(),]*)*))\h*,\h*((?1))\h*(?=\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bAssert\\.Equal\\(\\K\\h*((?(R)[^()]*(?:\\((?1)\\)[^()]*)*|[^,()]*(?:\\((?1)\\)[^(),]*)*))\\h*,\\h*((?1))\\h*(?=\\))', 'g')
const str = `Assert.Equal(false, General.CashFactor.IsHighlighted());
Assert.Equal(values, General.CashFactor.GetValue());
Assert.Equal(int.Parse(General.Time.Hour.GetValue()), this.GetLocalTimeEN(int.Parse(timezone.Timezone2.Zeitverschiebung), int.Parse(hour)));`;
const subst = `\2, \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);