#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\#(?<TAG>ZKI\.NET\-PTS)[|]{2}(?<Odesilatel>.{3})[|]{2}(?<Adresat>.{3})[|]{2}(?<Predmet>.{3})[|]{2}(?<Hodnota1>.+)[\|]{2}(?<Hodnota2>.*)\#$"
Local $sString = "#ZKI.NET-PTS||001||S01||PRE||002||T02#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")