use strict;
my $str = '#ZKI.NET-PTS||001||S01||PRE||002||T02#';
my $regex = qr/^\#(?<TAG>ZKI\.NET\-PTS)[|]{2}(?<Odesilatel>.{3})[|]{2}(?<Adresat>.{3})[|]{2}(?<Predmet>.{3})[|]{2}(?<Hodnota1>.+)[\|]{2}(?<Hodnota2>.*)\#$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}