package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\#(?<TAG>ZKI\.NET\-PTS)[|]{2}(?<Odesilatel>.{3})[|]{2}(?<Adresat>.{3})[|]{2}(?<Predmet>.{3})[|]{2}(?<Hodnota1>.+)[\|]{2}(?<Hodnota2>.*)\#$`)
var str = `#ZKI.NET-PTS||001||S01||PRE||002||T02#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}