#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^aid=n_557eb95ed07360\.45147988$"
Local $sString = "aid=n_557eb95ed07360.45147988" & @CRLF & _
"aid=n_557eb95ed07360045147988" & @CRLF & _
"aid=n_557eb95ed07360145147988" & @CRLF & _
"aid=n_557eb95ed07360245147988"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")