re = /^aid=n_557eb95ed07360\.45147988$/im
str = 'aid=n_557eb95ed07360.45147988
aid=n_557eb95ed07360045147988
aid=n_557eb95ed07360145147988
aid=n_557eb95ed07360245147988'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end