import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^aid=n_557eb95ed07360\\.45147988$";
final String string = "aid=n_557eb95ed07360.45147988\n"
+ "aid=n_557eb95ed07360045147988\n"
+ "aid=n_557eb95ed07360145147988\n"
+ "aid=n_557eb95ed07360245147988";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}