#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(x*)\1*(?!\1)(x+) % \1\b = \2\b"
Local $sString = "xxx % xx = x" & @CRLF & _
"" & @CRLF & _
"xxxxxx % xxxx = xx" & @CRLF & _
"" & @CRLF & _
"xxxxxxx % xx = x" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"should not match:" & @CRLF & _
"xxxxx % xxxxx = xxxxx" & @CRLF & _
"xxxxxxxxxxxxxx % xxx = xxxxx" & @CRLF & _
"xxxxxxxxxxxx % xx = x" & @CRLF & _
"xxxxx % xxx = xxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")