import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(x*)\\1*(?!\\1)(x+) % \\1\\b = \\2\\b";
final String string = "xxx % xx = x\n\n"
+ "xxxxxx % xxxx = xx\n\n"
+ "xxxxxxx % xx = x\n\n\n\n"
+ "should not match:\n"
+ "xxxxx % xxxxx = xxxxx\n"
+ "xxxxxxxxxxxxxx % xxx = xxxxx\n"
+ "xxxxxxxxxxxx % xx = x\n"
+ "xxxxx % xxx = xxxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}