$re = '/\b(x*)\1*(?!\1)(x+) % \1\b = \2\b/m';
$str = 'xxx % xx = x
xxxxxx % xxxx = xx
xxxxxxx % xx = x
should not match:
xxxxx % xxxxx = xxxxx
xxxxxxxxxxxxxx % xxx = xxxxx
xxxxxxxxxxxx % xx = x
xxxxx % xxx = xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);