re = /^(myApp.[a-zA-Z0-9].*?\b).*$/m
str = 'myApp.ComboPlaceHolderLabel,
myApp.GridTitleLabel);
myApp.SummaryLabel + \'</b></div>\');
myApp.NoneLabel + \')\') + \'</label></div>\';'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result