import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(?:msg=(?<msg>\\w+);?)?(?:name=(?<name>\\w+))?\\s*(?<rest>.*)";
final String string = "@msg=hello;name=test 1\n"
+ "@msg=hi 2\n"
+ "@name=tt 3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}