re = /@(?:msg=(?<msg>\w+);?)?(?:name=(?<name>\w+))?\s*(?<rest>.*)/
str = '@msg=hello;name=test 1
@msg=hi 2
@name=tt 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end