$re = '/@(?:msg=(?<msg>\w+);?)?(?:name=(?<name>\w+))?\s*(?<rest>.*)/';
$str = '@msg=hello;name=test 1
@msg=hi 2
@name=tt 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);