using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script(.*?)(?!<\/script>)(.*?)wrapperId={wrapper_id}(.*?)<\/script>";
string input = @"<script type=""text/javascript""> var blah; </script><script id=""bleh"" type=""text/javascript"" src=""//domain/test.js?siteid=270606&testmode=0&banner360=1&banner=0&placementid=0&tp=3&wrapperId={wrapper_id}"" > </script>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}