const regex = /<script(.*?)(?!<\/script>)(.*?)wrapperId={wrapper_id}(.*?)<\/script>/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script(.*?)(?!<\\\/script>)(.*?)wrapperId={wrapper_id}(.*?)<\\\/script>', 's')
const str = `<script type="text/javascript"> var blah; </script><script id="bleh" type="text/javascript" src="//domain/test.js?siteid=270606&testmode=0&banner360=1&banner=0&placementid=0&tp=3&wrapperId={wrapper_id}" > </script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}