re = /<script(.*?)(?!<\/script>)(.*?)wrapperId={wrapper_id}(.*?)<\/script>/
str = '<script type="text/javascript"> var blah; </script><script id="bleh" type="text/javascript" src="//domain/test.js?siteid=270606&testmode=0&banner360=1&banner=0&placementid=0&tp=3&wrapperId={wrapper_id}" > </script>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end