import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^0-9]|^)(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])\\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])(?=[^0-9]|$)";
final String string = "192.168.1.1\n"
+ "192.168.3.3\n"
+ "256.255.255.1\n"
+ "a12.11.2.344dsd\n"
+ "a12.11.2.35dsd\n"
+ "255.255.255.255\n"
+ "192.168.140.150\n"
+ "127.0.0.256\n"
+ "127.0.0.1\n"
+ "10.5.5.16\n"
+ "10.17.248.141\n"
+ "255.255.255.255\n"
+ "1.0.0.0\n"
+ "1.0.0.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}