const regex = /(?<=[^0-9]|^)(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])(?=[^0-9]|$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^0-9]|^)(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])\\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\\.(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])(?=[^0-9]|$)', 'mg')
const str = `192.168.1.1
192.168.3.3
256.255.255.1
a12.11.2.344dsd
a12.11.2.35dsd
255.255.255.255
192.168.140.150
127.0.0.256
127.0.0.1
10.5.5.16
10.17.248.141
255.255.255.255
1.0.0.0
1.0.0.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}