re = /(?<=[^0-9]|^)(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.(?:1?[0-9]{2}|2[0-4][0-9]|25[0-5]|[1-9])(?=[^0-9]|$)/m
str = '192.168.1.1
192.168.3.3
256.255.255.1
a12.11.2.344dsd
a12.11.2.35dsd
255.255.255.255
192.168.140.150
127.0.0.256
127.0.0.1
10.5.5.16
10.17.248.141
255.255.255.255
1.0.0.0
1.0.0.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end