package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\bmake(?:\s+(?:of|the|a))*\s+wish\b`)
var str = `make wish wish make a wish wish wish make the a wish make`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}