const regex = /\bmake(?:\s+(?:of|the|a))*\s+wish\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bmake(?:\\s+(?:of|the|a))*\\s+wish\\b', 'gmi')
const str = `make wish wish make a wish wish wish make the a wish make`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}