$re = '/\bmake(?:\s+(?:of|the|a))*\s+wish\b/mi';
$str = 'make wish wish make a wish wish wish make the a wish make';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);