using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[a-zA-Z]*-)A-?u-?t-?o-?m-?o-?b-?i-?l-?e\b";
string input = @"Auto-mobile, Aut-omobile, Automobil-e Automobile Comp-uter";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}