$re = '/\b(?=[a-zA-Z]*-)A-?u-?t-?o-?m-?o-?b-?i-?l-?e\b/m';
$str = 'Auto-mobile, Aut-omobile, Automobil-e Automobile Comp-uter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);