re = /\b(?=[a-zA-Z]*-)A-?u-?t-?o-?m-?o-?b-?i-?l-?e\b/m
str = 'Auto-mobile, Aut-omobile, Automobil-e Automobile Comp-uter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end