const regex = /[\d\.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d\\.]+', 'gm')
const str = `12.3.4.1.234
12f.3.4.1.234
sdgdfg
sdgsdg11
11dcghdfh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}