$re = '/[\d\.]+/m';
$str = '12.3.4.1.234
12f.3.4.1.234
sdgdfg
sdgsdg11
11dcghdfh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);