#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?:0+|[^1-9])\.)0+([a-z]+\b|%)"
Local $sString = ":0a" & @CRLF & _
":0.0a" & @CRLF & _
":00a" & @CRLF & _
":00.0a" & @CRLF & _
"" & @CRLF & _
":2.0a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")