$re = '/(?:(?:0+|[^1-9])\.)0+([a-z]+\b|%)/i';
$str = ':0a
:0.0a
:00a
:00.0a
:2.0a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);