// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:(?:0+|[^1-9])\.)0+([a-z]+\b|%)").unwrap();
let string = ":0a
:0.0a
:00a
:00.0a
:2.0a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}