import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Android |CPU iPhone OS )(?<version>[\\w+\\.]+)";
final String string = " 10.210.192.15 - - [12/Oct/2016:19:59:43 -0400] \"GET /rest/icontrol/login?expand=sites,instances,points,functions HTTP/1.1\" 401 6 \"-\" \"Mozilla/5.0 (Linux; Android 6.0.1; SAMSUNG-SM-G920A Build/MMB29K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/53.0.2785.124 Mobile Safari/537.36\"\n"
+ " \n"
+ " 10.210.192.5 - - [12/Oct/2016:19:50:06 -0400] \"GET /rest/icontrol/login?expand=sites,instances,points,functions HTTP/1.1\" 401 6 \"-\" \"Mozilla/5.0 (iPhone; CPU iPhone OS 10_0_2 like Mac OS X) AppleWebKit/602.1.50 (KHTML, like Gecko) Mobile/14A456\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}