// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Android |CPU iPhone OS )(?<version>[\w+\.]+)").unwrap();
let string = " 10.210.192.15 - - [12/Oct/2016:19:59:43 -0400] \"GET /rest/icontrol/login?expand=sites,instances,points,functions HTTP/1.1\" 401 6 \"-\" \"Mozilla/5.0 (Linux; Android 6.0.1; SAMSUNG-SM-G920A Build/MMB29K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/53.0.2785.124 Mobile Safari/537.36\"
10.210.192.5 - - [12/Oct/2016:19:50:06 -0400] \"GET /rest/icontrol/login?expand=sites,instances,points,functions HTTP/1.1\" 401 6 \"-\" \"Mozilla/5.0 (iPhone; CPU iPhone OS 10_0_2 like Mac OS X) AppleWebKit/602.1.50 (KHTML, like Gecko) Mobile/14A456\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}