package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?[0-9]+(?:\.[0-9]+)?(?:(?:e|E)(?:-|\+)?[0-9]+)?$`)
var str = `100
-100
12.34
4e10
4.2e-2
9e+5
1.2.3
v100
10.
.01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}